eWAY Phone Contact Issues
Incident Report for Eway System Status
Resolved
After monitoring for several hours we can confirm that the eWAY contact numbers are operating as expected.

If you have any further questions, please contact our team on 1800 10 65 65 or via support@eway.com.au
Posted Jun 24, 2020 - 10:10 AEST
Monitoring
The issue affecting our phone system has been resolved, and eWAY are available for phone calls.

We are currently monitoring the phone system to ensure stability. We thank you for you patience during this time.
Posted Jun 23, 2020 - 09:26 AEST
Investigating
eWAY are currently investigating an issue preventing our phone system from allowing calls to connect.

Our live chat services are currently available, accessible through eway.com.au at the bottom of the page - alternatively, you can contact us via support@eway.com.au

We appreciate your patience while we look into this issue, and will provide further updates shortly.
Posted Jun 23, 2020 - 08:21 AEST
This incident affected: Eway Website.